Observed Symptoms #
- Device does not power on
- No response to power button
- Two beeping sounds
Potential Causes #
- SSD electrical interference
- Possible power supply unit damage
- Battery pack connectivity issues
- Hardware failure
Troubleshooting Steps #
- Please check if the electric tape of SSD slot2 is in place;
- Please put UT2 on charge with original power adapter for over 1 hour (test the power adapter with other devices before that);
- Disconnect the external power source and long press on power button for 10 seconds to reboot it;
- If the issue persists, please reconnect the battery pack following the steps from video https://youtu.be/mQNO9rTWBoM;
- If the issue persists, please detach the battery pack and connect UT2 with external power source to reboot;
- If the issue persists, please share us the video that UT2 does not reboot with external power source through support@unifydrive.com
In case not resolve the issue #
Please contact us through support@unifydrive.com
Please remeber include your order information/ backer information, SN of the device.
Thanks for your patience and understanding.
